Nod Engine SDK => Modeling and NOT Editor => Topic started by: Maleficent on 2014-04-02, 04:20:56

Title: New Weapon Not Showing In Game
Post by: Maleficent on 2014-04-02, 04:20:56
Reading further through the forums, I saw another person had a similar issue and the problem was a missing leading underscore. I subsequently changed my file names for both the NOT and NOB files both to be _modpack.nob and _modpack.not, set them Read-Only, and repacked them all, and it now works. The tutorial is not clear on the fact that the files *must* have a leading underscore for the game to load them properly. Thanks =)

So, I followed the tutorial on how to make the custom sword step-by-step. It worked fine. I unpacked the NOB file to a work directory, made the modifications, then repacked it into a new nob file and copied the NOB file and the NOT files all to my root VtM:R directory. Everything worked fine, and I was able to make my sword in-game, and use it.

I then deleted the sword from my character, and deleted the custom NOT and NOB files from my VtM:R root directory.

Now, I wanted to make a Scythe that was custom, so I followed the same steps from the tutorial up to the point of copying the _Swords template and renaming it to _Swords_myproj. Instead, I copied the Scythe template and put it as a child of the _MeleeWeapons_DA template (I named them _MeleeWeapons_DA_mod and Scythe_mod, respectively). I made a new child template under that named Doom_Sickle, then went through and set all of my desired parameters for ITEM_EFFECTNAMEx and ITEM_EFFECTLEVELx, and modified my desired parameters for WEAPON_x as well.

Next I saved my new NOT file and set all of the NOT files to Read-Only, then put them into a new NOB file as Store and named the file modpack.nob

I then copied all of the NOT files and the new NOB file to my VtM:R root directory and loaded the game. The weapon does not show up in my ST panel inventory list to be added to a multiplayer LAN game. I have changed things about a few times, from modifying the Scythe_mod template itself, to renaming my Doom_Sickle template and modifying the attributes. Nothing seems to work.

Can someone please explain what I am doing wrong?

I have provided my custom NOB file at the following link: https://drive.google.com/file/d/0Bz5yzffb8jPTTVFGMTRKSEh6LUk/edit?usp=sharing
Title: Re: New Weapon Not Showing In Game
Post by: Javokis on 2014-04-02, 11:00:41
I just took a look at your nob file and noticed three things are wrong:

-Your NOT file name needs to have a _ in front of it so rename it to _modpack.NOT
-Your nob file doesn't have the misc>templates structure (the NOT files were in the root).
-Your nob file contained the system NOT files (multiplayer, global, darkage, and modernday) which is not recommended.

Check attachments for fix. ;)

Title: Re: New Weapon Not Showing In Game
Post by: Maleficent on 2014-04-02, 12:30:00
Thank you =)

I actually did get it to work finally. I have added more items to the NOB file as well. I ended up removing the system NOT files, but leaving my NOT files in the root of the NOB file without any other directory structure. It seems to work fine like this (for now). The issue was a lack of leading underscores for my files (which I thought was just what you had decided to name the stuff, not that it was required).